wiki:UseCaseGunnar

My First Gnowsis Experience

Distilled into UseCaseGunnarsVision

(I'm using Suse Linux, with a Gnome desktop...)

  1. Follow DevelopingFirstSteps ...
  2. Checkout many gnowsis projects into eclipse... and I mean MANY... this doubled the number of eclipse projects i had.
  3. Start gnowsis... it WORKS!
  4. Configure, setup hostname etc. (Wizard here? We can guess hostname, and have sensible defaults for other things)
  5. Add FileSystem adaptor... (sensible default URI again?)

First Task

Link a paper to a node representing it's conference.

  1. Open the FileSystem datasource... hmm... the user interface is ugly. And broken - the address bar is missing... (i'll attach a screenshot)
  2. Find the PDF if my papers - define a ESWC06 Wikiword for this
  3. This apparently does nothing - it doesn't appear anywhere else... and there is no Wiki where i can view it.
  4. Leo tells me to click the "Link" button (which is black) to accomplish what I want...
  5. Go back to miniquire, the PDF is listed at the bottom
  6. Define a new concept... mess it up, write something in the search box... Leo tells me to click "new", then write something in the dialog. Nothing happens. Clear search box, and try again, and it works.
  7. click "link to concept", thinking it works (it doesn't, but i didn't realise)

Second Task

Link an email about the same conference to the same node.

  1. Download xpi from gnowsis.org, install in firefox and thunderbird.
  2. Check out YET another project in eclipse.
  3. Restart gnowsis, configure....
  4. Try to add the email Service, BUT the add dialog wont let me select a directory... clicking add will only change to that directory. Writing it in the "selection" box does the same. Luckily the email service was actually already there...
  5. Configure the Imap datasource, mess up serv-4100 vs serv-3100 w and w/o dfki.uni-kl.de - Can we not enter get this info from thunderbird?
  6. Browse the imap datasource, the GUI is a bit broken and each folder appears 3-4 times.
  7. Browsing my INBOX with 400 messages is unvieldy... so onto... THUNDERBIRD!
  8. Add browse and link buttons in Thunderbird (could these not be added autoamtically when installing?)
  9. Click "Browse" on an email...
  10. Look at the RDF representation, N3 and TRIG, COOL! :)
  11. Add a wiki-node again... still does nothing :)
  12. Again go to link and to "link to concept", realise it does nothing
  13. Leo says, drag and drop to concept - this doesn't work.
  14. ... much later ...
  15. but dragging the concept to the link box does work - and then chosing the right relation and clicking "create" gives me the cheesy "relation saved" animation...
  16. But, browsing the concept shows no evidence that the link exists...
  17. nor does browsing the PDF that I added the link to ...
  18. oh well.

Other things

  • I randomly get "NullPointException: Null" errors
  • I get some jena error when opening the ontology manager( exception: com.hp.hpl.jena.shared.DoesNotExistException: home/grimnes/.gnowsis/data/ontologymanagerpath/urn%3Agnowsis%3Alocal%3Ahub%3Aontologymanager%3Adatasource.rdf )
  • In configure->datasources both the imap datasource and webpage datasource has the same description...
  • in the configure dialog box the finish and cancel buttons say "fini..." and "ca..."

(Some of these belong in trac tickets, no doubt)

Last modified 11 years ago Last modified on 01/17/06 14:25:15

Attachments (1)

Download all attachments as: .zip